Exchange Server 2010 auf Windows Server 2012, AppPools

Die Installation von Exchange Server 2010 auf Windows Server 2012 wird ab Exchange Server 2010 SP3 unterstützt. Problematisch ist der Weg über die Installation eines Exchange Servers mit Hilfe eines Exchange Server 2010 SP1-Datenträgers: Das Setup läuft ohne Fehlermeldung durch, und erst im Nachhinein stellt sich heraus, dass die Konfiguration Fehler aufweist. Die Konfiguration ist auch dann noch fehlerhaft, wenn das SP3 nachinstalliert wird!

Da Exchange Server 2010 diverse Test-Cmdlets mitbringt, ist dies ein guter Schritt, um die Exchange-Konfiguration zu prüfen. Das Cmdlet „Test-ECPConnectivity“ hat aufgezeigt, das etwas an der Serverkonfiguration fehlerhaft war. Ein Blick auf die ECP-Webseite brachte eine Meldung, dass etwas mit ASP.Net nicht sauber funktioniert (zu den Fehlern habe ich leider keine Screenshots). Schlussendlich brauchte das Prüfen der App-Pools im IIS folgendes Ergebnis:

AppPool

Damit Exchange in Zusammenarbeit mit dem IIS sauber funktioniert, darf lediglich der „DefaultAppPool“ auf ASP.Net v4.0 laufen. Alle anderen Pools müssen mit v2.0 laufen! Eine Korrektur der markierten Einträge brachte also das gewünschte Ergebnis. Auch besagtes Cmdlet lief ohne Fehlermeldung durch.

Bei Exchange Server 2010 auf Windows Server 2012 steckt der Teufel im Detail! Nur eine Exchange-Installation direkt über das SP3 bewirkt, dass der IIS korrekt konfiguriert wird.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.